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Lesson #8 - Tracking Project Progress
Due Date: Check Class Schedule/Syllabus

MS Project

Objectives





Track the actual progress of tasks
Updating a Project
Compare baseline data to actual and scheduled data
Viewing a Network Diagram

Once the project starts, it's time to begin tracking the actual progress of tasks and resources. Tracking is
the process of gathering and entering task information into the schedule. You can track progress by
entering all or some of the actual information.
In the previous lesson, we complete our scheduling and resource assignments. For this lesson, we will
assume our project is underway and that several tasks have either finished or are partially finished. We will
then determine if our project is behind or ahead of schedule.

Tracking Progress
Before we can begin tracking progress, the project schedule should be fully developed and a baseline plan
should be set. Once work begins, progress should be tracked throughout the project. The more often we
update the information, the easier it is to identify problems and take corrective action.
When actual information is entered, the project is automatically recalculated. For this reason, task progress
should be entered starting at the top of the task list and continuing down the list.
There are three types of dates stored for each task:
Scheduled: Tasks that haven't started yet or are in progress.
Actual: Tasks that are in progress or are completed.
Baseline: Originally planned dates. These dates are used to compare the original plan with the
actual dates and scheduled dates. Baseline dates do not change.

There are five types of actual data that can be entered in MS Project:
Actual start and finish dates
Percentage completion
Actual duration and remaining duration
Actual and remaining work
Actual and remaining costs
Our project was scheduled to begin on October 1, 2007 and end on November 19, 2007. For the purposes
of this lesson, we will assume that it is now October 29, 2007 and the project is underway
1.
2.

Open your MyLab7_XXX.mpp and save as MyLab8_XXX where XXX are your initials
OR
To ensure that all students are starting from the same scheduling parameters, download the following
file from your class web site: Lesson8Start.mpp
a) Open the above file in MS Project and then immediately…
b) Save as MyLab8_XXX.mpp, where XXX are your initials.
c) Under File - Properties change the author's name and the manager's name to your name. For
Company name, enter MGMT404 followed by your professor’s name
d) Change the name of the main summary task (task #1) to reflect your name.
e) Once you have made those changes, save the file.
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Finally, before continuing, under Project menu, select Project Information.
Change the current date to October 29, 2007. (Important: You must do this every time you open
this file! - for this lesson and lessons 9 and 10)

Entering Actual Dates
1.
2.
3.

Make sure you are in Gantt Chart View with Table:Entry.
Select task 3, Inventory Current Equipment.
From the Tools menu, point to Tracking and select Update Tasks. The Update Tasks dialog box
appears:

Figure 1
4.
5.
6.

In the Actual area (left side), click the Finish down arrow.
Select/Enter October 2, 2007 and click OK.
The actual finished date is entered and a checkmark is displayed in the indicator field, and a progress
bar is displayed on the Gantt chart.
7. From the Tools menu, point to Tracking and select Update Tasks.
8. Notice the actual start date has been entered, the actual duration was 2 days, the % complete is 100%
and the remaining duration is 0. Click Cancel.
9. Position your mouse on the checkmark in the indicator field and a tip box will open showing you
when the task was completed.
10. With completed tasks, you can either enter the actual finished date or enter 100% complete or both!

Entering Actual and Remaining Durations
1.
2.
3.
4.

Select task #7, Research Products and Services.
From the Tools menu, point to Tracking and select Update Tasks.
Click the Actual Duration up arrow until 2 days (2d) is displayed.
Click the Remaining Duration down arrow until 1 day (1d) is displayed. Click OK.
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Figure 2
5.
6.

7.
8.

From the Tools menu, point to Tracking and select Update Tasks. (See Figure 2)
Notice the actual start date is entered as October 16 and percentage completion is 67%. (Note, since
this task was originally at 3.5 days, you have just subtracted one-half day to the duration. Given that is
4 hours, you have just subtracted 8 hours of work (2 units of resource) from your overall Project.
While your entry table now reflects a 3-day duration, the baseline, however, will still be at the original
3.5 days. Obviously this task did not take as long as you expected. Click Cancel.
You will notice there is no icon in the task information column, but if you look at your Gantt chart for
this task, you will see that the task is partially filled in with a black bar (indicating progress).
With partially completed tasks, you can either enter the actual duration with remaining duration or
enter the percentage completed. You can also enter any different start date than that reflected.
However to affect the change you must press OK.

Entering Percentage Completion
1.
2.

There is also a Tracking table and a Tracking toolbar that you can also use to update task information.
On the View menu, click on More Views…and then select Task Sheet. Press Apply. (See figure 3).

Figure 3
3.
4.

Notice the Gantt chart has been removed from your view.
Again, go back to the View menu, point to Table and select Tracking.
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Your table should look similar to Figure 4.

Figure 4
6.
7.

Again, go back to the View menu, point to Toolbars and select Tracking.
A toolbar should now appear similar to Figure 5. (Hover your mouse over each icon to see what each
one represents).

Figure 5
8. Select task 4, Access Current Department Needs, on the Task table.
9. On the Tracking toolbar, click the 75% complete button.
10. The actual start date is entered as scheduled (October 2) since the predecessor was completed on time.
The actual and remaining durations are updated as scheduled; 2.25 days has been completed (75% of
3 days) and there is .75 days remaining on the task. Your overall project completion percentage is
13% and this phase of the project (Creating Proposal) is 35% complete.
Note: using percentage completion data for tracking can be somewhat subjective and should only be used
when everyone involved understands what the percentage means.

Entering Actual Work
Sometimes, you need to update or report actual work hours performed on a task. There are times the work
that you projected for a resource or resources may be different than what they actually performed.
1.
2.

From the View menu, click on Task Usage.
Your screen should now appear as in Figure 6. (You may have to widen the task name column to see
the entire task name).
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Figure 6
3.
4.
5.

From the Format menu, point to Details, and then select Actual Work.
Notice the Details column splits into two rows: Work and Actual Work.
Go to task 7, Research Products and Services, and scroll, if necessary, until you see the hours of
work for the System Analyst. (See Figure 7).

Figure 7
6.
7.

In the row for Systems Analyst, select the cell with 16 hours for Tuesday (Oct 16) that is in the
Actual Work row (Act.Work). (DO NOT change the Work row!).
Change the 16 hours to 24 hours. Note the icon that appears in the Indicator Column. This indicates
that the work assignment has been changed. (Did you notice any other changes, such as duration and
what happened to that Thursday?)

On your own, do the following: (Review beginning of lab before performing these steps).
1.
2.
3.
4.
5.

Edit/track task 5, Design and Diagram New System, as 2 days actual duration with remaining 3 days
duration. (Hint: Do NOT press OK…continue with next step…)
Edit task 5 for an actual start date of Friday, October 5, 2007.
Now, press OK
Edit/track task 6, Create Proposal for Accounting, as 50% completed.
For task 6, Create Proposal for Accounting, change the Project Manager's actual work for Friday,
October 12, 2007 from 10 hours to 8 hours.
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Entering Changes in Fixed Costs
To enter changes to fixed costs, after you have begun a project, do the following:
1.
2.
3.
4.
5.

Change to Gantt chart view. From the View menu, point to Table and select Cost.
Move the Gantt chart so you can see all the columns of this table.
Go to task #14, Install Wiring.
In the Fixed Cost column, change $4,000 to $6,400
Notice the column Baseline still says $4,000, but the total cost column says $6,400 for a variance of
$2,400. (Note the variance column).

Tracking actual costs, other than fixed costs, can only be done after the task is completed or the remaining
work is zero. In our lesson, the only task that is completed is task #3. To change that task's actual cost
would require changing the details of our task sheet to add cost information and then change that
information. For this lab, we will not be doing this.
(Note: MS Project automatically calculates actual costs, so you must turn off this option to manually
change actual costs.)

Comparing the Baseline to Actual Data
When we save our project with a baseline, we did so because we need to have something to serve as a basis
for comparing costs, work and dates for task and resources. It is the only way we can know if we are onschedule, within budget, etc.
Project baselines and actual data can be viewed graphically in charts or numerically in tables. The
following describes the tools in MS Project to analyze and compare baseline, actual and scheduled data:
Tool
Tracking Gantt

Type
Chart

Variance

Table

Work
Cost
Cost Overbudget
Slipping Tasks
Work Overbudget

Table
Table
Task Filter
Task Filter
Resource Filter

Description
Displays the actual and baseline information for tasks in a
graphical format
Displays the difference between actual information and baseline
information
Displays the difference between actual and baseline work hours
Displays the difference between actual and baseline costs
Displays all tasks with a cost greater than baseline cost
Displays all tasks that are behind in schedule
Displays all resources with scheduled work greater than baseline
work.

You can quickly see overall progress by displaying project statistics:
1.
2.
3.

From the Project menu, click Project Information.
Click Statistics. Note: You may also use the icon on the Tracking toolbar to display these statistics.
You should see the information as in figure 8. The Percent Complete is for the entire project.
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Figure 8
Or you can view the Tracking Gantt Chart:
1.
2.

From the View menu, select Tracking Gantt.
The Gantt chart now is displayed showing actual versus baseline scheduling information. (Figure 9).

Figure 9
3.

4.

Another graphical representation of your project is the Network Diagram. The Network Diagram
view displays tasks and task dependencies in a network or flowchart format. A box (sometimes called
a node) represents each task, and a line connecting two boxes represents the dependency between the
two tasks. By default, the Network Diagram view displays one diagonal line through a task that is in
progress and crossed diagonal lines through a completed task.
To see the Network Diagram, select Network Diagram from your View Bar on the left (or select it
from the View Menu). Your screen will look something like Figure 10.
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You can change to zoom levels to see the more of the diagram, but for now leave it at 100%.
MS Project’s Network Diagram is similar to an AON chart. You may want to view the legend on this
diagram to see what each shape and color means.

Another way to view information about the baseline is in a report showing Earned Values. Earned values
are a measure of cost of the work performed up to a given date in a project. Earned values are calculated
using the baseline costs and actual work to show whether the actual costs incurred are over- or underbudget. Earned values indicate how much of the budget (or baseline) cost should have been spent based on
the work completed. Earned values are used to forecast whether a task/project will finish over- or underbudget.
At this point, save your file and print out the following reports: (use proper header information)
1.
2.
3.
4.

Project Summary
Overbudget Tasks
Earned Value (Make sure you have reset your current date per instruction at beginning of this lab).
The Network Diagram. (Keep at 100%. The printout may be from 4-7 pages).
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Review Questions
Name ____________________________
Answer the following questions using complete sentences:
1) Why is it best not to enter a percentage (%) completion?

2) According to your Project Summary, is this project on schedule? Will you be over or under
budget and by how much?

3) After printing out the Earned Value report, define the following terms, using MS Project Help:
BCWS:

BCWP:

ACWP:

SV:

CV:

EAC:

BAC:

VAC:

Attach your four printouts, in print order, to the back of this sheet and submit by the
lesson due date.
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